Parandus: teie arvutis olev rakendus vajab .NET Framework 3.5

Fix App Your Pc Needs

Kui kasutate Windows 8 või 10, olete ilmselt märganud hüpikut, mis vajab teid .NET framework 3.5 installimiseks. Hüpikaknad võivad olla juhuslikud, kui kasutate rakendusi taustal või käivitamisel. Hüpikaken ütleb:

„Teie arvutis olev rakendus vajab järgmist Windowsi funktsiooni: .NET Framework 3.5 (sisaldab Net 2.0 ja 3.0)”





Hüpikaken on tavaliselt ehtne, kuid selle võib käivitada iga programm, mis seda raamistikku vajab, sealhulgas pahavara. Kui otsustate installimise vahele jätta, võib hüpikaken ilmuda uuesti, kui proovite programmi installida või kui proovite mõnda programmi käivitada. Internetist allalaadimine ja arvutisse installimine toob aga tagasi ainult masendavama vea, mille raamistik on juba installitud. Selles artiklis selgitatakse, miks see hüpik ilmub, mis on .NET-i raamistik ja miks seda teie arvutis vaja on. Lõppkokkuvõttes anname teile meetodid selle kohta, kuidas saate .NET Framework 3.5 oma arvutisse installida.



Et mõista, miks on vaja .NET raamistikku 3.5 ja miks see taotlus ilmub, peame kõigepealt mõistma, mis on .NET raamistik. Programmeerimisel on raamistik rakenduste programmeerimisliideste (API) kogu, mis on tavaliselt koodide jagatud teek, millele arendajad saavad rakendusi arendades helistada. Nii ei pea nad koodi ise nullist kirjutama, säästes väärtuslikku aega ja julgustades seepärast programmeerijat keskenduma rohkem sellele, mida programm suudab. .NET-i raamistikus nimetatakse seda jagatud koodi teeki raamklassi raamatukoguks (FCL). Jagatud teegi koodid võivad täita igasuguseid erinevaid funktsioone ja neid on tuhandeid selliseid koode. Näiteks on selles raamistikus kood võrgu muu seadme pingimiseks või dialoogibokside „Ava nimega” või „Salvesta nimega” kaasamiseks mõeldud kood.

Lisaks standardiseeritud koodidele pakub .NET-raamistik käituskeskkonda rakenduste käitamiseks, mis on loodud raamistikukoodide abil. Käitusaegne keskkond on omamoodi liivakast, milles rakendused töötavad; sama, mis juhtub Java-rakendustega. .NET-i käituskeskkond kannab nime Common Language Runtime (CLR). Samuti haldab CLR mälu ja protsessori lõime, haldab programmi erandeid ja haldab turvalisust. Koodid enne nende käivitamist kompileerides eraldab käituskeskkond tarkvara arvuti riistvarast, tagades seega kodeeritud programmi töötamise mis tahes arvutis.

.NET-raamistik töötati välja mitme operatsioonisüsteemi jaoks, kuid oma varalise olemuse tõttu kasutatakse seda enamasti Windowsis. .NET raamistiku versioone on olnud mitu. Esialgne idee oli, et uuemad versioonid ühilduksid tagurpidi vanemate versioonide abil loodud koodidega. Siiski saadi aru, et see ei saa enam nii olla. Kuid .NET Framework versioon 3.5 sisaldab koode versioonist 3.0 ja versioonist 2.0, on seetõttu tagurpidi ühilduv ainult nende versioonidega. Uusim versioon (V. 4.6) ei ole tagurpidi ühilduv ja seetõttu käitatakse seda tavaliselt koos teiste versioonidega.



Mis põhjustab .NET framework 3.5 on vajalik Windows 8/10 hüpikaken

Windows 8 ja Windows 10 on tavaliselt varustatud nii .NET Framework versioonidega 3.5 kui ka 4.6. Kuid sisse on lülitatud ainult versioon 4.6 ja peate sisse lülitama .NET Framework 3.5. Seetõttu käivitavad kõik programmid, mis kasutavad .NET versiooni 3.5 raamistikku, hüpikakna, mille .NET Framework 3.5 tuleb installida, kuna versioon 4.6 pole tagurpidi ühilduv. Selle raamistiku abil tehti arvukalt programme, kuna see toetab programme, mis on kodeeritud koodidega C #, C ++, F #, Visual Basic ja veel paar tosinat. Uue versiooni kasutamise julgustamiseks on vanem .NET framework 3.5 seetõttu teie arvutis keelatud. Kuid mõned kodeerijad levitavad vajaliku versiooni koos oma programmidega.

Kui kuvatakse viga, mis ütleb, et programmi käivitamiseks on teie arvutis vaja .NET-i versiooni 3.5, võite selle arvutisse installimiseks kasutada alltoodud meetodeid. .NET Framework 3.5 sisaldab versioone 3.0 ja 2.0 ning lahendab seetõttu hüpikud, paludes teil installida versioonid 3.0 ja 2.0.

1. meetod: lülitage programmides ja funktsioonides sisse .NET Framework 3.5

Õnneks on .NET framework 3.5 levitatud koos Windows 8 või 10-ga. Kõik, mida peate tegema, on see sisse lülitada ja lubada seda kasutada programmidel, mis seda kutsuvad. Seetõttu kinnitab allalaaditud .NET-i raamistiku installimine lihtsalt seda, et installitav versioon on juba teie arvutis. Selle funktsiooni sisselülitamiseks toimige järgmiselt.

  1. Vajutage Windowsi võti + R jooksu avamiseks
  2. Tüüp appwiz.cpl programmide ja funktsioonide akna avamiseks käivitage tekstikast ja vajutage sisestusklahvi
  3. Klõpsake lingil “ Windowsi funktsioonide sisse- või väljalülitamine ”.
  4. Otsi ' .NET Framework 3.5 (sisaldab .NET 2.0 ja 3.0) '
  5. Märkige vasakul olev ruut ja klõpsake nuppu OK, et .NET Framework 3.5 sisse lülitada.
  6. Taaskäivitage arvuti, kui seda palutakse.

2. meetod: installige ja lubage .NET Framework 3.5, kasutades DISM-i

Käsurea tööriista DISM (Deployment Image Servicing and Management) abil saate installida ja aktiveerida .NET framework 3.5 oma arvutisse. Selleks vajate oma Windows 8/10 DVD- või ISO-faili.

  1. Laadige DVD salve ja sulgege see või paremklõpsake oma .ISO-failil ja valige ‘mount’; ISO-fail laaditakse virtuaalse kettana / draivina (pange tähele selle draivi tähte).
  2. Käivitusakna avamiseks vajutage Windowsi klahvi + R
  3. Sisestage käivitatud tekstikasti CMD ja vajutage käsuviiba avamiseks sisestusklahvi
  4. Sisestage või kleepige allolev käsk oma CMD aknasse:

    DISM / Online / Enable-Feature / FeatureName: NetFx3 / All / LimitAccess / Source: D: sources sxs

  5. Kus D: on teie Windowsi installifailide (DVD või virtuaalne draiv) tee.
  6. Oodake, kuni installimine on edukalt lõpule viidud
  7. Taaskäivitage arvuti, kui seda palutakse.

Võite vaadata ka minu teist artiklit, mis selgitab, kuidas seda teha Minge üle versioonile .NET Framework 3.5

4 minutit loetud